From: Junio C Hamano Date: Fri, 21 Oct 2011 00:37:02 GMT Subject: Re: [PATCH] gitweb: provide a way to customize html headers Message-ID: <7vmxcv89jl.fsf@alter.siamese.dyndns.org> In-Reply-To: <201110210046.34679.lenaic@lhuard.fr.eu.org> Lénaïc Huard writes: > +GITWEB_SITE_HTMLHEADER = > GITWEB_SITE_HEADER = > GITWEB_SITE_FOOTER = Is it just me or does the inconsistency between the existing two variables and this new one with a very similar name stand out like a sore something? It might have been better if GITWEB_SITE_(HEADER|FOOTER) were named with "_FILE" suffix, but as long as we consider/declare insert_file is the norm and in-place inclusion of mini-string is an oddball, it is sufficient to call this GITWEB_SITE_HTML_HEAD_STRING to avoid confusion? Perhaps GITWEB_SITE_HEADER_STRING and GITWEB_SITE_FOOTER_STRING might turn out to be useful in the future for in-place inclusion of mini-strings, and when that happens, you two would thank me for this suggestion ;-)