From: Junio C Hamano Date: Wed, 29 May 2013 22:46:36 GMT Subject: Re: [PATCH 1/6] t/send-email.sh: add test for suppress self Message-ID: <7vmwrdqu9f.fsf@alter.siamese.dyndns.org> In-Reply-To: <20130529214403.GA5956@redhat.com> "Michael S. Tsirkin" writes: >> > +test_suppress_self () { >> > + test_commit $3 && >> > + test_when_finished "git reset --hard HEAD^" && >> > + { >> > + echo "#!$SHELL_PATH" >> > + echo sed -n -e s/^cccmd--//p \"\$1\" >> > + } > cccmd-sed && >> > + chmod +x cccmd-sed && >> >> We can use write_script for this kind of thing, I think. > > Important? > It's open-coded elsewhere in this test. Not that important, other than that it is nice not to spread what the old tests did before write_script was introduced to new ones, as that is one more thing to update when somebody feels like it. > If we don't want to use \, this can also be done like this: > > FOO << EOF && > BLABLA > EOF > BAR && > VAR > > I think this is what you suggest. Yup, that is exactly what I meant (but no leading indentation before BAR and VAR). That way, it is a lot more clear where the input is (the BLABLA is fed to FOO and BAR and VAR do not have anything to do with it). >> > + grep '^Cc:' msghdr1-$3 > actual-no-cc-$3 && \ >> > + test_cmp expected-no-cc-$3 actual-no-cc-$3 OK, so this is where the message begins, with the commit title "test supress-cc.self...". >> > +test suppress-cc.self $3 with name $1 email $2 >> > + >> > +$3 >> > + >> > +cccmd--"$1" <$2> >> > + >> > +Cc: "$1" <$2> >> > +Cc: $1 <$2> >> > +Signed-off-by: "$1" <$2> >> > +Signed-off-by: $1 <$2> >> > +EOF >> > +} >> > + >> > +test_expect_success $PREREQ 'self name is suppressed' " >> > + test_suppress_self 'A U Thor' 'author@redhat.com' 'self_name_suppressed' >> > +" >> > + >> > test_expect_success $PREREQ 'Show all headers' ' >> > git send-email \ >> > --dry-run \