From: Junio C Hamano Date: Tue, 22 Feb 2011 18:11:09 GMT Subject: Re: [PATCH v3 00/15] Mark "init", "clone", and "add" output for translation Message-ID: <7vhbbwdjnm.fsf@alter.siamese.dyndns.org> In-Reply-To: <20110221101229.GA32137@elie> Jonathan Nieder writes: > This series still includes the skeleton gettext.h wrapper. > > Changes from v1: > > - clearer commit messages, hopefully > - clearer documentation for GETTEXT_POISON in the makefile > > Please feel free to try it out, complain, ack, send patches, and so > on. > > Jonathan Nieder (2): > i18n: do not poison translations unless GIT_GETTEXT_POISON envvar is > set > update-index --refresh --porcelain: add missing const I took this series (minus 4/15), which roughly corresponds to up to 13/72 of Ævar's original. A few quick comments: * 01/15 Thanks for guarding the header file from double inclusion. I have this nagging feeling that the inline _() function might be too clever for some compilers (non gcc and perhaps older versions of gcc), but we can always ifdef it away if it turns problematic. * 02/15 I am not entirely happy that it is a too generic name to contaminate namespace of programs that may want to get i18n support while wanting to catch bugs with their own unrelated poisoning scheme. As to Malkovich, I tend to agree with your reasoning that code that emit messages prefixed by "#" rebase relies on should be restructured to limit the scope of translation to just the body of these lines, and that should be done in a separate patch. * 04/15 Deferred per request from Ævar.