From: Junio C Hamano Date: Tue, 17 May 2011 02:36:36 GMT Subject: Re: [PATCH 01/11] packed_object_info_detail(): do not return a string Message-ID: <7vfwoehx3f.fsf@alter.siamese.dyndns.org> In-Reply-To: Thiago Farina writes: > In the commit message you say to return "enum object_name". Maybe > change from int to enum object_name here and below? As other functions that return -1 on error return int as a convention, I do not think it is a good change. As you may have noticed, "enum object_name" is not correct. It should be "enum object_type" I think.