From: Junio C Hamano Date: Mon, 15 Jul 2013 15:37:08 GMT Subject: Re: [PATCH 7/7] push: document --lockref Message-ID: <7vfvvfdecb.fsf@alter.siamese.dyndns.org> In-Reply-To: <20130715044454.GA2962@elie.Belkin> Jonathan Nieder writes: > Now suppose my relay has some downtime. That's fine --- I can still > maintain the mirror by running the same commands on another machine. > But when the old relay comes back up, "push --lockref" will fail and > "pu" and "next" in my mirror are not updated any more. > > That is why I said that --force is more appropriate than --lockref > for this application. Sure.