From: Junio C Hamano Date: Mon, 12 Sep 2011 04:28:07 GMT Subject: Re: [PATCH v2 0/7] Improved infrastructure for refname normalization Message-ID: <7vehzmbd0o.fsf@alter.siamese.dyndns.org> In-Reply-To: <1315637443-14012-1-git-send-email-mhagger@alum.mit.edu> Michael Haggerty writes: > Patch series re-roll: Thanks for working on this. I very much like the general direction of the series, the strategy to avoid wholesale audit of the callers and marking the places that needs fixing with "_unsafe()". There were a few minor things that looked worth mentioning while reviewing, though. - (style) You seem to be fond of pre-increment a lot, but in general our codebase prefers post-increment especially when the end result does not make any difference, e.g. for (i = 1; ...; ++i) { ... - (series structure) It might make the series progress easier to follow if you introduced check_ref_format_unsafe() in the same commit where you change check_ref_format() to take flags parameter.