From: Junio C Hamano Date: Tue, 16 Feb 2010 19:41:57 GMT Subject: Re: [PATCH v2 4/4] Refactoring: remove duplicated code from builtin-checkout.c and merge-recursive.c Message-ID: <7vd405m0hm.fsf@alter.siamese.dyndns.org> In-Reply-To: <1266276411-5796-5-git-send-email-michael.lukashov@gmail.com> Michael Lukashov writes: > diff --git a/merge-recursive.c b/merge-recursive.c > index cb53b01..5999ae2 100644 > --- a/merge-recursive.c > +++ b/merge-recursive.c > @@ -599,7 +599,7 @@ struct merge_file_info > merge:1; > }; > > -static void fill_mm(const unsigned char *sha1, mmfile_t *mm) > +void fill_mm(const unsigned char *sha1, mmfile_t *mm) > { > unsigned long size; > enum object_type type; Isn't a much better home for this function next to read_mmfile() in xdiff-interface.c? Perhaps it would make sense to morph it into something like this int read_mmblob(mmfile_t *ptr, const unsigned char *sha1); for consistency.