From: Junio C Hamano Date: Mon, 10 Jun 2013 19:17:27 GMT Subject: Re: [PATCH 2/3] test: improve rebase -q test Message-ID: <7vbo7dhj20.fsf@alter.siamese.dyndns.org> In-Reply-To: <20130610172708.GH2091@goldbirke> SZEDER Gábor writes: > With such a helper function this could be reduced to a single line: > > test_string_equal "(master)" "$(__git_ps1)" > > without loss of functionality or debuggability, because in case of a > failure it would output something like this (bikesheddable, of > course): > > Error: > expected: "(master)" > got: "((deadbeef...))" Yeah, that looks sensible.