From: Junio C Hamano Date: Sun, 18 Nov 2012 07:46:46 GMT Subject: Re: [PATCH] Rename V15_MINGW_HEADERS into CYGWIN_OLD_WINSOCK_HEADERS Message-ID: <7va9ufjqu1.fsf@alter.siamese.dyndns.org> In-Reply-To: <50A7A161.9020805@gmail.com> Mark Levedahl writes: >> ... >> - V15_MINGW_HEADERS = YesPlease >> + CYGWIN_OLD_WINSOCK_HEADERS = YesPlease >> > WINSOCK is certainly a part of the win32 api implementation, but it is > is the entire win32api that changed, not just the tiny bit dealing > with sockets. > Basically, WINDOWS.h, and everything it includes, and all of the dlls > it touches, and the .o files, changed. > ... So my suggestion in the bike shedding > category is to > > s/V15_MINGW_HEADERS/CYGWIN_V15_WIN32API/ Sounds sensible.