From: Junio C Hamano Date: Thu, 08 Nov 2007 20:48:37 GMT Subject: Re: [NEW REPLACEMENT PATCH] git-checkout: Add a test case for relative paths use. Message-ID: <7v7iks31lm.fsf@gitster.siamese.dyndns.org> In-Reply-To: Johannes Schindelin writes: >> + mkdir dir2 && >> + echo bonjour > dir2/file2 && >> + git add dir2/file2 && >> + git commit -m "populate tree" >> + >> +' > > Please lose the empty line before the closing quote. (This applies to all > tests.) I personaly find the extra blank lines before and after the indented test body easier to read. That is.. test_expect_sucess 'test description comes here' ' test command 1 && test command 2 && ... test command N ' I agree with all other suggestions from your message.