From: Junio C Hamano Date: Mon, 18 Jun 2012 17:50:36 GMT Subject: Re: [PATCH 1/2] sha1_name: don't trigger detailed diagnosis for file arguments Message-ID: <7v62ao4ihf.fsf@alter.siamese.dyndns.org> In-Reply-To: Matthieu Moy writes: > My version reads as > > try something; > if (it failed && I'm only here to report an error) > report_error(); > > which I find easier to understand. I agree that _this_ part is easy to understand when written that way. But then shouldn't there be a blanket "The caller is here only to report an error, but all the previous code didn't find any error, so there is something wrong" check much later in the code before it returns a success? Or am I being too paranoid?