From: Junio C Hamano Date: Wed, 18 Apr 2012 23:42:11 GMT Subject: Re: [PATCH] git-submodule.sh: Don't use $path variable in eval_gettext string Message-ID: <7v4nsgk3os.fsf@alter.siamese.dyndns.org> In-Reply-To: <4F8DAFDA.1020108@ramsay1.demon.co.uk> Ramsay Jones writes: > As an alternative, we finesse the problem by renaming the $path > variable to $sm_path (submodule path). This fixes the problem on > MinGW along with all test failures on cygwin (t7400.{7,32,34}, > t7406.3 and t7407.{2,6}). We note that the foreach subcommand > provides $path to user scripts (ie it is part of the API), so we > can't simply rename it to $sm_path. Which might mean that foreach is unusable on systems whose environment variables are case insensitive, as whatever command spawned by foreach has its $PATH clobberred. It is not a regression to them, so it is not urgent to address it, but going forward, perhaps we can encourage users of _all_ platforms to use $sm_path for portability?