From: Junio C Hamano Date: Thu, 20 Sep 2012 21:26:01 GMT Subject: Re: [PATCH v2 00/14] new git check-ignore sub-command Message-ID: <7v4nms9yja.fsf@alter.siamese.dyndns.org> In-Reply-To: <1348170383-15751-1-git-send-email-git@adamspiers.org> Adam Spiers writes: > Adam Spiers (14): > Update directory listing API doc to match code > Improve documentation and comments regarding directory traversal API > Rename cryptic 'which' variable to more consistent name > Rename path_excluded() to is_path_excluded() > Rename excluded_from_list() to is_excluded_from_list() > Rename excluded() to is_excluded() > Refactor is_excluded_from_list() > Refactor is_excluded() > Refactor is_path_excluded() > For each exclude pattern, store information about where it came from > Refactor treat_gitlinks() > Extract some useful pathspec handling code from builtin/add.c into a > library > Provide free_directory() for reclaiming dir_struct memory > Add git-check-ignore sub-command Please retitle these to have a short "prefix: " that names a specific area the series intends to touch. I retitled your other series to share "test :" as their common prefix. Thanks.