From: Junio C Hamano Date: Tue, 06 Mar 2012 23:12:02 GMT Subject: Re: [PATCH 2/2] Support Out-Of-Tree Valgrind Tests Message-ID: <7v399lqq7x.fsf@alter.siamese.dyndns.org> In-Reply-To: <87mx7te3ng.fsf@smith.obbligato.org> "David A. Greene" writes: > Ok, I see. So TEST_DIRECTORY is supposed to point to the "official" > location of git's tests and testing support files. That wasn't clear to > me. That is how I read the intent of what test-lib.sh does. I do not think it has much to do with official-ness, but more about where you find pieces of the framework from (e.g. diff-lib.sh, lib-gpg.sh, etc.) > I think naming is a big issue here. Perhaps TEST_DIRECTORY needs a > better name, something like GIT_TEST_SUPPORT or such? I do not think so; the biggest problem I see is that nobody documented these variables like Thomas did in the previous message we saw in this thread (and Thomas knew more about them than all because he added t/perf/ recently and had to play with these variables). Once the roles of variables are well understood, I do not think it is worth renaming the existing uses.