From: Junio C Hamano Date: Sun, 08 May 2011 20:19:06 GMT Subject: Re: [PATCH 16/48] i18n: git-pull eval_gettext + warning message Message-ID: <7v1v09rlmt.fsf@alter.siamese.dyndns.org> In-Reply-To: <20110508165254.GA20654@pcpool00.mathematik.uni-freiburg.de> "Bernhard R. Link" writes: >> + echo >&2 "$(eval_gettext "Warning: fetch updated the current branch head. >> +Warning: fast-forwarding your working tree from >> +Warning: commit \$orig_head.")" > > echo "$(...)" > > sounds quite wasteful and harder to read than necessary. > The same also happens in later patches. A very good point. Just letting eval_gettext write out to >&2 should be both sufficient and inifinitely more readable.