From: Junio C Hamano Date: Wed, 01 Feb 2012 22:33:34 GMT Subject: Re: [PATCH v3 1/2] Factor find_pack_entry()'s core out Message-ID: <7v1uqe2ngh.fsf@alter.siamese.dyndns.org> In-Reply-To: <7vaa522oum.fsf@alter.siamese.dyndns.org> Junio C Hamano writes: > Nicolas Pitre writes: > >>> +static int find_pack_entry_1(const unsigned char *sha1, >>> + struct packed_git *p, struct pack_entry *e) >> >> This looks all goot but the name. Pretty please, try to find something >> that is more descriptive than "1". Suggestions: >> "find_pack_entry_lookup", "find_pack_entry_inner", etc. > > Perhaps "find_pack_entry_in_pack(sha1, e, p)"? > That would go well with the caller "find_pack_entry(sha1, e)". I amended 1/2 (and adjusted 2/2 to match) to call it fill_pack_entry. Will push out the result tonight.