From: Dragan Simic Date: Sun, 21 Apr 2024 14:18:25 GMT Subject: Re: [PATCH] format-patch: allow --rfc to optionally take a value, like --rfc=WIP Message-ID: <7a60e90310024a06ba105892b54965a8@manjaro.org> In-Reply-To: Hello Junio, On 2024-04-19 19:03, Junio C Hamano wrote: > Phillip Wood writes: >>> @@ -1932,7 +1944,9 @@ int cmd_format_patch(int argc, const char >>> **argv, const char *prefix) >>> N_("mark the series as Nth re-roll")), >>> OPT_INTEGER(0, "filename-max-length", &fmt_patch_name_max, >>> N_("max length of output filename")), >>> - OPT_BOOL(0, "rfc", &rfc, N_("use [RFC PATCH] instead of >>> [PATCH]")), >>> + OPT_CALLBACK_F(0, "rfc", &rfc, N_("extra"), >>> + N_("add (default 'RFC') before 'PATCH'"), >>> + PARSE_OPT_NONEG|PARSE_OPT_OPTARG, rfc_callback), >> >> This is a change in behavior as it looks like we previously accepted >> "--no-rfc" is that deliberate? > > I just matched the subject-prefix without thinking. Will fix. > > Here is what I plan to squash in, but we are about to enter the > pre-release stabilization period, so the progress on this new > feature will have to slow down. Let me remind you about the need to also support "[PATCH RESEND]", for example, in this new feature. Please see my earlier response [1] for a possible solution. Even some instructions for submitting patches, in some projects, specify "[PATCH RESEND]" as the expected prefix, not "[RESEND PATCH]". Thus, suffixes for the prefix should be supported. [1] https://lore.kernel.org/git/84dcb80be916f85cbb6a4b99aea0d76b@manjaro.org/