From: Kristoffer Haugsbakk Date: Thu, 08 Jan 2026 07:16:37 GMT Subject: Re: [PATCH v2 08/10] packfile: inline `find_kept_pack_entry()` Message-ID: <76bd89da-462a-4eb4-86b0-915f649629c8@app.fastmail.com> In-Reply-To: <20251218-b4-pks-pack-store-via-source-v2-8-62849007ce21@pks.im> On Thu, Dec 18, 2025, at 07:55, Patrick Steinhardt wrote: > The `find_kept_pack_entry()` function is only used in > `has_oject_kept_pack()`, which is only a trivial wrapper itself. Inline s/has_oject_kept_pack/has_object_kept_pack/ > the latter into the former. > > Furthermore, reorder the code so that we can drop the declaration of the > function in "packfile.h". This allows us to make the function file-local. > > Signed-off-by: Patrick Steinhardt > --- >[snip]