From: Derrick Stolee Date: Thu, 20 Sep 2018 13:42:00 GMT Subject: Re: [PATCH 3/4] git-commit-graph.txt: refer to "*commit* graph file" Message-ID: <6b1cb43e-a1a8-921f-cd66-3697609854e0@gmail.com> In-Reply-To: On 9/20/2018 9:38 AM, Martin Ågren wrote: > On Thu, 20 Sep 2018 at 14:50, Derrick Stolee wrote: >> On 9/19/2018 12:30 PM, Martin Ågren wrote: >>> The full name, by the way, is not the "commit-graph file" with a dash, >>> cf. the synopsis. Use the dashless form. (The next commit will fix the >>> remaining few instances of the "commit-graph file" in this document.) >> The file is literally at ".git/objects/info/commit-graph" which is why I >> tried to use "commit-graph" everywhere. Why do you think that "commit >> graph" is better? > I noticed the discrepancy between "commit graph file" and "commit-graph > file" and briefly wondered if it was intentional, i.e., if it meant > anything, but the dash vs no dash seemed pretty random to me. In order > to figure out which was (more) correct, I went to the synopsis. But > admittedly, that was quite arbitrary. For all I know, "the commit-graph > file" could be the better choice, grammatically. Yeah, the fact that I was inconsistent forced you to make a choice. Sorry for that. > There is the file named "commit-graph" as you note, but it might on the > other hand just as well be called "cg.bin". I would probably try to let > the filename "commit-graph" influence the user manual only if we would > have written "cg.bin" instead. For example, if we would talk about how > you might get out of a hole by deleting the "<...>/commit-graph" > ("cg.bin") file manually. > > But that's certainly not to argue against "the commit-graph file". I'd > be happy to s/commit graph file/commit-graph file/g instead to keep > others from wondering if these are two slightly different things. And > if the concept and the file have the same name, all the better. > > If you agree, I'll do that in a v2, where I will also note in the > Options section that `--object-dir` takes a ``. I think "commit-graph" is better. Thanks for also catching the `...` formatting. Thanks! -Stolee