From: René Scharfe Date: Sat, 25 Feb 2017 21:39:29 GMT Subject: Re: [PATCH 2/2] commit: don't check for space twice when looking for header Message-ID: <6462e74c-1ee7-7ed0-0695-9889df803943@web.de> In-Reply-To: <20170225201522.uan52fwey6zjosym@sigill.intra.peff.net> Am 25.02.2017 um 21:15 schrieb Jeff King: > On Sat, Feb 25, 2017 at 08:27:40PM +0100, René Scharfe wrote: > >> Both standard_header_field() and excluded_header_field() check if >> there's a space after the buffer that's handed to them. We already >> check in the caller if that space is present. Don't bother calling >> the functions if it's missing, as they are guaranteed to return 0 in >> that case, and remove the now redundant checks from them. > > Makes sense, and I couldn't spot any errors in your logic or in the > code. Thanks for checking! >> static inline int standard_header_field(const char *field, size_t len) >> { >> - return ((len == 4 && !memcmp(field, "tree ", 5)) || >> - (len == 6 && !memcmp(field, "parent ", 7)) || >> - (len == 6 && !memcmp(field, "author ", 7)) || >> - (len == 9 && !memcmp(field, "committer ", 10)) || >> - (len == 8 && !memcmp(field, "encoding ", 9))); >> + return ((len == 4 && !memcmp(field, "tree", 4)) || >> + (len == 6 && !memcmp(field, "parent", 6)) || >> + (len == 6 && !memcmp(field, "author", 6)) || >> + (len == 9 && !memcmp(field, "committer", 9)) || >> + (len == 8 && !memcmp(field, "encoding", 8))); > > Unrelated, but this could probably be spelled with a macro and strlen() > to avoid the magic numbers. It would probably be measurably slower for a > compiler which doesn't pre-compute strlen() on a string literal, though. sizeof(string_constant) - 1 might be a better choice here than strlen(). René