From: Kaartic Sivaraam Date: Wed, 20 Sep 2017 08:03:02 GMT Subject: Re: [PATCH] doc: camelCase the config variables to improve readability Message-ID: <63517904-6e14-6e12-31dd-ad91b2a70004@gmail.com> In-Reply-To: <20170919202201.GD75068@aiede.mtv.corp.google.com> On Wednesday 20 September 2017 01:52 AM, Jonathan Nieder wrote: > nit: Git's commit messages describe the current behavior of Git in the > present tense. Something like: Thanks for the clarification. I was once searching Documentation/SubmittingPatches to see if there is any guideline about the tense to use. Unfortunately, this seems to be an undocumented guideline. Fixed it. My little nit: I don't think this is really the a "current behaviour of *Git*". It's just a document, you see ;-) > These manpages' references to config variables are hard to read because > they use all-lowercase names, without indicating where each word ends > and begins in the configuration variable names. > > Improve readability by using camelCase instead. Git treats these names > case-insensitively so this does not affect functionality. Thanks for providing the solution, also. Used it with a little tweak. > This also is just more consistent with the rest of the docs. Yes. > FWIW, with or without the commit message tweaks mentioned above, > Reviewed-by: Jonathan Nieder Thanks. > Thanks for your attention to detail. You're welcome. Just for the note, I sent this because I had a hard time finding the words that made up those config variable names when reading that part of the 'git branch' documentation. I thought I could help a little in improving it. --- Kaartic