From: Phillip Wood Date: Wed, 15 Jul 2026 09:20:58 GMT Subject: Re: [PATCH v2 06/10] sequencer: simplify handing of fixup with conflicts Message-ID: <5c9991e0-81f8-41f8-b78c-b436d4a494b1@gmail.com> In-Reply-To: Hi Oswald On 13/07/2026 15:09, Oswald Buddenhagen wrote: > On Mon, Jul 13, 2026 at 02:17:23PM +0100, Phillip Wood wrote: >> Commit e032abd5a0 (rebase: fix rewritten list for failed pick, >> 2023-09-06) introduced an early return when res == -1, so if we enter >> this conditional block then res is positive. After the last couple >> of commits the only possible positive value is 1 so we can simplify >> the code by removing the conditional call to intend_to_amend() and > >> call it error_with_patch() instead. >> > that part makes no sense, It should say "call it in error_with_patch() instead" > subverting the argumentation. > (as-is, i actually can't follow the logic, but i suppose it would be > clear with (much) more diff context. i'm not sure whether the commit > message is supposed to substitute for that, or the reviewer is supposed > to deal with that on their end.) Its tricky because error_with_patch() isn't changed at all, we change error_failed_squash() to tell error_with_patch() to call intend_to_amend(). I've expanded the commit message to explain that better. Thanks Phillip