From: Xing Xin Date: Tue, 11 Jun 2024 12:47:54 GMT Subject: Re:Re: [PATCH v5 3/4] unbundle: extend options to support object verification Message-ID: <5b47b697.c049.19007573522.Coremail.bupt_xingxin@163.com> In-Reply-To: At 2024-06-11 17:11:09, "Patrick Steinhardt" wrote: >On Tue, Jun 11, 2024 at 06:42:05AM +0000, Xing Xin via GitGitGadget wrote: >> From: Xing Xin >> >> This commit extends object verification support in `bundle.c:unbundle` >> by adding two new options to `verify_bundle_flags`: >> >> - `VERIFY_BUNDLE_FSCK_ALWAYS` explicitly enables checks for broken >> objects. It will be used to add "--fsck-objects" support for "git >> bundle unbundle" in a separate series. >> - `VERIFY_BUNDLE_FSCK_FOLLOW_FETCH` is designed to be used during fetch >> operations, specifically for direct bundle fetches and _bundle-uri_ >> enabled fetches. When enabled, `bundle.c:unbundle` invokes >> `fetch-pack.c:fetch_pack_fsck_objects` to determine whether to enable >> checks for broken objects. Passing this flag during fetching will be >> implemented in a subsequent commit. >> >> Note that the option `VERIFY_BUNDLE_FSCK_ALWAYS` takes precedence over >> `VERIFY_BUNDLE_FSCK_FOLLOW_FETCH`. > >Thanks, the new sequence of commits is much easier to follow. It also >shows that there is no user of `VERIFY_BUNDLE_FSCK_ALWAYS` at the end of >this series. So maybe we should drop that flag? OK, let's focus on the fetching scenarios in this patch series. >If you do that, then I'd also propose to merge patches 2 and 3 into one >given that both are quite trivial and related to each other. I merged patches 3 and 4 instead to combine the new option definition and usage logic, as the two are more closely related and more trivial. :) Xing Xin >Other than that this series looks good to me. > >Patrick >