From: Torsten Bögershausen Date: Sat, 07 Nov 2015 06:28:30 GMT Subject: Re: [PATCH] run-command: detect finished children by closed pipe rather than waitpid Message-ID: <563D9A0E.8050405@web.de> In-Reply-To: <1446853737-19047-1-git-send-email-sbeller@google.com> On 07.11.15 00:48, Stefan Beller wrote: > > +enum child_state { > + FREE, > + WORKING, > + WAIT_CLEANUP, > +}; This kind of "generic names" feels are begging for name clash, some day, may be in the future. How about something like this: > + GIT_CP_FREE, > + GIT_CP_WORKING, > + GIT_CP_WAIT_CLEANUP,