From: Felipe Contreras Date: Sat, 12 Oct 2013 11:18:42 GMT Subject: Re: [PATCH 16/20] revision: trivial style fixes Message-ID: <52593012d7d28_5f30b31e74588ea@nysa.mail> In-Reply-To: <52591180.3010103@googlemail.com> Stefan Beller wrote: > While talking about trivia, what is the projects stance on > such constructs here? > while (foo) > bar(); > foobar(); > > I've seen an empty line between the bar(); and the foobar(); often, which suits readability. > What's the stance on such an empty line here? I don't think there's any guideline on that. Personally I choose depending on the context. ---- void test(void) { while (foo) bar(); foobar(); } ---- ---- while (meh) { /* * bunch of stuff */ } while (foo) bar(); foobar(); ---- Cheers. -- Felipe Contreras