From: Célestin Matte Date: Tue, 11 Jun 2013 22:24:43 GMT Subject: Re: [PATCH v3 21/28] git-remote-mediawiki: Put long code into a subroutine Message-ID: <51B7A3AB.5090803@ensimag.fr> In-Reply-To: <7vli6gd582.fsf@alter.siamese.dyndns.org> Oops, forgot to take this into account before sending v4 of my series of patch. I just noticed that, sorry... Le 11/06/2013 17:42, Junio C Hamano a écrit : > I am guessing that the new sub, parse_command, uses a local @cmd and > this is an attempt to avoid using the same name, but this renaming > of the variable is not explained. This is indeed what I intended to do. > I also wonder if you need this global @cmd/@cmds. Instead of > passing cmdref, wouldn't it be simpler to have the helper split the > line, i.e. something like... > > sub parse_command { > my ($line) = @_; > my @cmd = split(/ /, $line); > unless (defined @cmd) { > return 0; > } > ... check capabilities, list, etc.... > return 1; > } > > while () { > chomp; > if (!parse_command($_)) { > unknown command, aborting > last; > } > } > > -- Célestin Matte