From: Célestin Matte Date: Tue, 11 Jun 2013 20:13:28 GMT Subject: Re: [PATCH v3 07/28] git-remote-mediawiki: Rewrite unclear line of instructions Message-ID: <51B784E8.8020700@ensimag.fr> In-Reply-To: <7vhah4bjtf.fsf@alter.siamese.dyndns.org> Le 11/06/2013 20:09, Junio C Hamano a écrit : > Matthieu Moy writes: > >>> my ($namespace) = @_; >>> my $namespace = shift; >>> >>> My impression has been that both are equally common, >> >> The second is the most common in git-remote-mediawiki (but I don't have >> any preference nor know what is recommended elsewhere). > > I wasn't implying I prefer the former. I was just being curious, > and if the latter is more prevalent in the code _and_ Perlcritique > does not have any issue with it, it is perfectly fine. Perlcritic doesn't have an issue with any of both cases. I think the second method is clearer when there is only one argument, because it makes it clear that there is only one. -- Célestin Matte