From: Phillip Wood Date: Sat, 06 Apr 2024 13:50:29 GMT Subject: Re: [RFC] bisect: Introduce skip-when to automatically skip commits Message-ID: <4bedcad2-218a-4b16-88a7-cc70cc126af3@gmail.com> In-Reply-To: Hi Olliver On 06/04/2024 11:06, Olliver Schinagl wrote: > On 06-04-2024 03:08, Junio C Hamano wrote: >> Olliver Schinagl writes: >> >>> Hey all, >>> >>> I've also got my work on a branch in my repo, if that helps to look at >>> things, https://gitlab.com/olliver/git/-/tree/skip_bisect >>> >>> Also included is a script to be used as an example. I opted to use >>> `git show`, which is nice because it works both on commits, but also >>> on notes. >>> >>> Anyway, any thoughts on the bellow before I send the full series? >>> >>> Olliver >> >> I would not write get_skip_when() before studying the same file to >> see if there already is a helper to read the whole file used in the >> vicinity (like strbuf_read_file(), perhaps). > > Fair enough. I'm a little worried about optimization vs readability. I > think it makes it mre clear what the code does in its current form; but > I'll investigate. Bisecting shouldn't be a computational often happening > thing, so I'm not to worried about performance. But I'm not too familiar > with the git code base, so I don't know either :p If you search builtin/bisect.c you'll see some existing callers of strbuf_read_file() that read other files like BISECT_START. Those callers should give you an idea of how to use it. >> >> I do not have enough concentration to follow changes to >> bisect_auto_next() is reasonable.  Especially I do not know why >> "bisect-skip_when" wants to exist and what it is trying to do, >> besides the fact that its name looks horrible ;-). >> > naming things, sure. I can look into this absolutly :) For me it's not just the name but the whole hook thing - do we really need that rather than just the command line option? The other thing I wondered about is the exit code handling for the "--skip-when" script. In Junio's example in an earlier message he used a successful exit to mean "skip this commit" and an unsuccessful exit to mean "test this commit". To me that matches the name of the option - we skip when the script given to "--skip-when" is successful. Copying the mechanism used by "git bisect run" seems a bit cumbersome as we only need to know whether to skip or not, we don't need a special way of distinguishing "skip this commit" from "this commit is good" and "this commit is bad" Best Wishes Phillip > But in short, bisect_auto_next was returning just after checkout It > seemed. So after checkout, running the script seemed sensible. But I > look at it as a normal git user. So you checkout, test your commit, skip > to the next one if applicable. > > > I'll think of your two comments, and see if I can address them as you > regain your concentration :p > > But seeing that these are your main concerns, I'm more confident I'm not > completly on the wrong path here. > > Olliver >