From: Johannes Sixt Date: Fri, 09 Apr 2010 12:20:16 GMT Subject: Re: [PATCH] branch: say "Reset to" in reflog entries for 'git branch -f' operations Message-ID: <4BBF1B80.8050307@viscovery.net> In-Reply-To: Am 4/9/2010 14:03, schrieb Matthieu Moy: > Michael J Gruber writes: > >> But I also have a functional question: Is "start_from" really the ref >> *to* which the branch is reset? I hope reset does it right. > > I don't know which is which, but if start_from is the destination of > the ref, then it should be renamed. I don't think we want to have this > > snprintf(msg, sizeof msg, "branch: Reset to %s", > ^^ > start_name); > ^^^^^ > > in the code. I think the patch is right. The "start" part refers to where the branch forks off of existing history. In the case were an existing branch is pointed to a new commit, the "Reset to" is indeed correct. IIUC, the "start_name" is what was given on the command line as fork point (or HEAD if not given). For example, after git branch -f thebranch master~23 the reflog of 'thebranch' would now read as "Reset to master~23". -- Hannes