From: Johannes Sixt Date: Thu, 23 Jul 2009 07:27:42 GMT Subject: Re: janitoring Message-ID: <4A6810EE.4030902@viscovery.net> In-Reply-To: <1248298475-2990-1-git-send-email-madcoder@debian.org> Pierre Habouzit schrieb: > [PATCH 2/3] refactor: use bitsizeof() instead of 8 * sizeof() > > use a macro for CHAR_BIT * sizeof(...), I tend to find it more > readable than 8 * sizeof(...) in the code. YMMV. > > [PATCH 3/3] janitor: add DIV_ROUND_UP and use it. > > Just use linux/kernel.h DIV_ROUND_UP(a, b), it's way easier to read > than (a + b - 1) / (b). Quite frankly, using these two macros means that code readers have to learn their meaning although the original code pieces are (IMO) well-known paradigms. Moreover, DIV_ROUND_UP hides that b is evaluated twice. I am not enthused by these patches (though, I don't see a reason to object). -- Hannes