From: Stephen Boyd Date: Mon, 18 May 2009 08:06:23 GMT Subject: Re: [PATCH 2/3] parse-options: add PARSE_OPT_CUSTOM_ARGH for complicated argh's Message-ID: <4A1116FF.8030008@gmail.com> In-Reply-To: <7vmy9aetc8.fsf@alter.siamese.dyndns.org> Junio C Hamano wrote: > You are asking a wrong person. I am terrible at naming things; think > "rerere" ;-). > > But I think custom-arghelp is much better than multargs. You are asking > "use this help for argument value _literally_", so another possibility > perhaps is PARSE_OPT_ARGHELP_LITERAL. > > After all, there probably are many other valid reasons why you may not > want "s/.*/<&>/" blindly applied to your string. One reason may be > because the string describes multiple arguments, but I suspect that it is > not the only one. It is better to name the option after what it does, > than naming it after one sample reason why you might want to use that > option. Ok. I think PARSE_OPT_LITERAL_ARGH might be good; until someone comes up with a better one of course.