From: Han-Wen Nienhuys Date: Tue, 28 Nov 2006 10:45:12 GMT Subject: Re: [PATCH/RFC] "init-db" can really be just "init" Message-ID: <456C1338.2020303@xs4all.nl> In-Reply-To: <7vmz6cfsuw.fsf@assigned-by-dhcp.cox.net> Junio C Hamano escreveu: > I was not sure about this for quite some time, thinking that it > might make sense to default the behaviour of init-db for bare > repositories and give init as a user-level wrapper to drive > init-db to add customization suitable for repositories with > working trees. List? wouldn't using --bare be more consistent for bare repos? >> Maybe that could be a good rule of thumb to have all porcelainish >> commands not have any hyphen in their name, like "diff", "commit", >> "add", etc. ? > > I was also hoping that would become the case except verify-tag, > cherry-pick, and format-patch. why not shorten them to "pick" and "verify"? --