From: René Scharfe Date: Thu, 23 Mar 2017 19:18:26 GMT Subject: Re: [PATCH] refs.c: use skip_prefix() in prettify_refname() Message-ID: <4382e211-63f6-811f-6f33-1cf5d2c087a8@web.de> In-Reply-To: <20170323155012.6148-1-szeder.dev@gmail.com> Am 23.03.2017 um 16:50 schrieb SZEDER Gábor: > This eliminates three magic numbers. > > Signed-off-by: SZEDER Gábor > --- > refs.c | 10 +++++----- > 1 file changed, 5 insertions(+), 5 deletions(-) > > diff --git a/refs.c b/refs.c > index e7606716d..0272e332c 100644 > --- a/refs.c > +++ b/refs.c > @@ -366,11 +366,11 @@ int for_each_glob_ref(each_ref_fn fn, const char *pattern, void *cb_data) > > const char *prettify_refname(const char *name) > { > - return name + ( > - starts_with(name, "refs/heads/") ? 11 : > - starts_with(name, "refs/tags/") ? 10 : > - starts_with(name, "refs/remotes/") ? 13 : > - 0); > + if (skip_prefix(name, "refs/heads/", &name) || > + skip_prefix(name, "refs/tags/", &name) || > + skip_prefix(name, "refs/remotes/", &name)) > + ; /* nothing */ > + return name; Nice, but why add the "if" when it's doing nothing? René