From: Beat Bolli Date: Tue, 25 Jul 2023 23:03:54 GMT Subject: Re: [PATCH v2 2/2] wrapper: use trace2 counters to collect fsync stats Message-ID: <2f39e481-84d1-097c-ec47-5357dbc36798@drbeat.li> In-Reply-To: On 25.07.23 21:31, Junio C Hamano wrote: > Junio C Hamano writes: > >> I also spotted this change since v1: >> >> - Rename trace2 counters to use "-" (not "_") as inter-word separators. >> >> Since I do not seem to be able to find any review comments regarding >> the variable naming in the v1's thread, let's ask stakeholders. >> >> Are folks involved in the trace2 subsystem (especially Jeff >> Hostetler---already CC:ed---who presumably has the most stake in it) >> OK with the naming convention of the multi-word variable? This is >> the first use of multi-word variable name in tr2_ctr, and thus will >> establish whatever convention you guys want to use. I do have a >> slight preference of "writeout-only" over "writeout_only" but that >> is purely from visual appearance. If there is a desire to keep the >> names literally reusable as identifiers in some languages used to >> postprocess trace output, or something, that might weigh >> differently. > > I heard absolutely nothing since I asked the above question last > week, so I'll take the absense of response as absense of interest in > the way how names are spelled. > > Therefore, let me make a unilateral declaration here ;-) The trace2 > counters with multi-word names are to be named using "-" as their > inter-word separators. Any patch that adds new counters that do not > follow the convention will silently dropped on the floor from now on. > > Let's move this patch forward by merging to 'next' soonish. Works for me :-) Cheers!