From: René Scharfe Date: Tue, 26 Nov 2019 15:23:31 GMT Subject: [PATCH] name-rev: use skip_prefix() instead of starts_with() Message-ID: <23925fba-9413-0596-b21a-f49aac922f88@web.de> Let skip_prefix() advance refname to get rid of two magic numbers. Signed-off-by: René Scharfe --- builtin/name-rev.c | 6 ++---- 1 file changed, 2 insertions(+), 4 deletions(-) diff --git a/builtin/name-rev.c b/builtin/name-rev.c index b0f0776947..c261d661d7 100644 --- a/builtin/name-rev.c +++ b/builtin/name-rev.c @@ -161,10 +161,8 @@ static const char *name_ref_abbrev(const char *refname, int shorten_unambiguous) { if (shorten_unambiguous) refname = shorten_unambiguous_ref(refname, 0); - else if (starts_with(refname, "refs/heads/")) - refname = refname + 11; - else if (starts_with(refname, "refs/")) - refname = refname + 5; + else if (!skip_prefix(refname, "refs/heads/", &refname)) + skip_prefix(refname, "refs/", &refname); return refname; } -- 2.24.0