From: Ævar Arnfjörð Bjarmason Date: Thu, 13 Oct 2022 19:16:49 GMT Subject: Re: [PATCH v3 5/8] rebase: rename merge_base to branch_base Message-ID: <221013.86bkqfleh5.gmgdl@evledraar.gmail.com> In-Reply-To: <00f70c9034452bd87c82fb3aea9658aec32f2ec1.1665650564.git.gitgitgadget@gmail.com> On Thu, Oct 13 2022, Phillip Wood via GitGitGadget wrote: > From: Phillip Wood > > merge_base is not a very descriptive name, the variable always holds > the merge-base of 'branch' and 'onto' which is commit at the base of > the branch being rebased so rename it to branch_base. To me "branch" means or has heavier implications of "named branch" than just a merge base, and this command is perfectly happy to work on commits disconnected from any named branch. But more to the point, the rebase docs for --onto discuss a "merge base", so you'd read those, and then encounter this code talking about a "branch base", and wonder what the difference was...