From: Ævar Arnfjörð Bjarmason Date: Thu, 19 May 2022 19:28:58 GMT Subject: ab/env-array (was: What's cooking in git.git (May 2022, #05; Mon, 16)) Message-ID: <220519.86sfp52u91.gmgdl@evledraar.gmail.com> In-Reply-To: On Mon, May 16 2022, Junio C Hamano wrote: > * ab/env-array (2022-04-06) 3 commits > - run-command API users: use "env" not "env_array" in comments & names > - run-command API: rename "env_array" to "env" > - cocci: add a rename of "struct child_process"'s "env_array" to "env" > > Rename .env_array member to .env in the child_process structure. > > On hold. > source: I'm not sure if the "on hold" status is wanted here, or a holdover from around the release time (per https://lore.kernel.org/git/?q=ab%2Fenv-array); but in this case I think it would be very nice if we could advance this sooner than later. I'm aware of a couple of topics that would semantically conflict with it if re-submitted (IIRC the rest of submodule-in-C is one). So if we're going to do the s/env_array/env/g at all it seems better to do it sooner than later. Thanks.