From: Brian Gernhardt Date: Mon, 13 Sep 2010 04:14:25 GMT Subject: Re: [PATCH] t7003: Use test_commit instead of custom function Message-ID: <214E9A5B-E9CE-4B98-88EC-744DBE1F3C32@gernhardtsoftware.com> In-Reply-To: <1284156396-81023-1-git-send-email-brian@gernhardtsoftware.com> On Sep 10, 2010, at 6:06 PM, Brian Gernhardt wrote: > Not only is this unneeded code duplication, it also was something > simply waiting to fail on case-insensitive file systems. So replace > all uses of make_commit with test_commit. To be more specific: this causes a failure in next on case-insensitive HFS+. The commit that finally triggered the problem is 7ec344d: "filter-branch: retire --remap-to-ancestor", by using `git reset --hard A` which got confused on if 'A' was 'refs/branches/A' or './a' However, the patch applies to master or maint. ~~ Brian