From: Ævar Arnfjörð Bjarmason Date: Tue, 23 Nov 2021 01:27:33 GMT Subject: Re: [PATCH v3 2/2] config: include file if remote URL matches a glob Message-ID: <211123.86pmqrwtf2.gmgdl@evledraar.gmail.com> In-Reply-To: <1c1a07a0b65d4bbbb0f2628a3ddf1980e37d5065.1637020610.git.jonathantanmy@google.com> On Mon, Nov 15 2021, Jonathan Tan wrote: > +`hasremoteurl`:: > + The data that follows the keyword `hasremoteurl:` is taken to Both here.. > + die(_("remote URLs cannot be configured in file directly or indirectly included by includeIf.hasremoteurl")); ..and here... > + if (skip_prefix_mem(cond, cond_len, "hasremoteurl:", &url, ...but not here (C code).. > + * For internal use. Include all includeif.hasremoteurl paths without ..but here.. > +test_expect_success 'includeIf.hasremoteurl' ' ..and also here etc., let's consistently camelCase config keys whenever we're not using them for lookups in the C code. I.e. "includeIf.hasRemoteUrl" (possibly "includeIf.hasRemoteURL"?). It makes them a lot easier to read, and makes the end-user documentation & messaging more consistent.