From: Rubén Justo Date: Tue, 16 Apr 2024 19:24:39 GMT Subject: Re: [PATCH] add-patch: response to invalid option Message-ID: <20685fa0-815f-4cdf-95e0-7206588552b5@gmail.com> In-Reply-To: <15f9252c-212f-43eb-84f3-6046fb2fab38@gmail.com> On Tue, Apr 16, 2024 at 10:41:32AM +0100, phillip.wood123@gmail.com wrote: > Thanks for working on this, it is a nice follow up to your last series. Thank you for your interest! > > On 15/04/2024 20:00, Rubén Justo wrote: > > > > + } else { > > + err(s, _("Unknown option '%s' (use '?' for help)"), > > As this is an interactive program I think "Unknown key" would be clearer. Maybe you have "interactive.singleKey" set to "true"? Perhaps "key" refers more to the key pressed by the user. My impression is that "option" have a clearer and wider audience. > Something like this (which also adds coverage for '?' and 'p') I know we don't have a test for the help. I noticed this in my other series. And I decided not to include a test for it then. Maybe in this series it makes sense. However, I would prefer to keep a test only on the new error message. Thanks.