From: Vsevolod Myalitsin Date: Tue, 08 Sep 2026 21:38:39 GMT Subject: [PATCH] advice: use global config for default branch name Message-ID: <20260908213840.37833-1-ub4nal@mail.ru> In-Reply-To: Hi Junio, > Should it only about "global vs local"? I am wondering if we ever > want to suggest "system". In any case, these three things are > called "scope" in "git config --help", so perhaps rename the new > member to "config_scope" or "scope_hint" or something? Agreed. I will rename "global_hint" to "scope_hint" so that the field describes the configuration scope rather than just the global case. > Have you considered going in the other direction to narrow the > interface instead of widening? Instead of passing .level and .key > separately from the caller to this function, I wonder if it makes > it more future-proof to pass &advice_setting[type]. Yes, I agree that passing the "advice_setting" itself is cleaner and more future-proof. I will change "vadvise()" to take a pointer to the corresponding "advice_setting" instead. Unfortunately, I did not notice your message in time and had already sent v2. I will implement these changes in v3. Thanks for the suggestions. Best, Vsevolod R4NC