From: Jeff King Date: Sun, 22 Feb 2026 09:41:58 GMT Subject: Re: [PATCH] object-file: use `container_of()` to convert from base types Message-ID: <20260222094158.GA1319383@coredump.intra.peff.net> In-Reply-To: On Sat, Feb 21, 2026 at 11:07:08PM -0800, Junio C Hamano wrote: > Perhaps a fix-up patch on top of the topic branch like this? > > ----- >8 ----- > Subject: [PATCH] object-file.c: avoid container_of() of a NULL container > [...] > static void prepare_loose_object_transaction(struct odb_transaction *base) > { > - struct odb_transaction_files *transaction = > - container_of(base, struct odb_transaction_files, base); > + struct odb_transaction_files *transaction = NULL; > + > + if (base) > + transaction = > + container_of(base, struct odb_transaction_files, base); That works, but you can also use container_of_or_null() in the initializer. IMHO the result is easier to read. -Peff