From: Jeff King Date: Sun, 15 Feb 2026 08:57:55 GMT Subject: [PATCH 0/4] cleaning up ref-filter lstrip/rstrip code Message-ID: <20260215085755.GA86262@coredump.intra.peff.net> In-Reply-To: On Fri, Feb 13, 2026 at 09:15:57PM -0800, Collin Funk wrote: > I generally don't like the casts like in rstrip_ref_components and > rstrip_ref_components because they force you to write this: > > free((char *)free_ptr); > > And the const doesn't really benefit readability, in my opinion. Agreed. It is especially egregious in this case because the const variable is called to_free, and so its only purpose is to be non-const. ;) > That is a bit of a seperate topic than fixing the warning, though, so > I left them as-is. It is a separate topic, but I feel like this is a good opportunity to make this code less horrible. That is, there are some obvious low-hanging cleanups that make the code more readable, and as a side effect we clean up the const confusion. In such cases I think it is worth veering off the path a little. I was going to catalog the numerous flaws I found, but by the time I explained them, I had basically written patches and commit messages. So here is what I would propose instead. I hope I'm not stealing your thunder nor knocking us too far off our goal. The first three I hope are no-brainers, and the final one fixes the glibc const issue. The fourth is perhaps more risky. [1/4]: ref-filter: factor out refname component counting [2/4]: ref-filter: simplify lstrip_ref_components() memory handling [3/4]: ref-filter: simplify rstrip_ref_components() memory handling [4/4]: ref-filter: open-code slash search in rstrip_ref_components() ref-filter.c | 54 +++++++++++++++++----------------------------------- 1 file changed, 17 insertions(+), 37 deletions(-) -Peff