From: Harald Nordgren Date: Sat, 10 Jan 2026 14:44:03 GMT Subject: Re: [PATCH v17 1/2] refactor format_branch_comparison in preparation Message-ID: <20260110144403.16387-1-haraldnordgren@gmail.com> In-Reply-To: <20260110110629.18501-1-haraldnordgren@gmail.com> > Why is this variable called "push_sti"? Calling the return value of > stat_tracking_info() "sti" was klumsy but understandable. It would > have been much easier to follow the code if the variable were named > after what it _means_ in this particular caller's code flow, like > "cmp_fetch" (comparison on the fetching side, by convention negative > signals an error, and zero signals 'the same'). Perhaps rename "sti" > and "push_sti" at the same time to make them more symmetric? I renamed to 'push_cmp_fetch' and 'push_cmp_fetch' now. I think on my first reading I misunderstood your comment. > Other than this minor nit, this step looks nicely done (and the > previous one is also good). Thanks a lot! Harald