From: Maxim Cournoyer Date: Tue, 24 Jun 2025 01:48:54 GMT Subject: [PATCH v3 0/3] git-credential-netrc: better symbolic port names support Message-ID: <20250624014857.3748-1-maxim@guixotic.coop> In-Reply-To: <20250620041239.27839-1-maxim@guixotic.coop> Most suggestions from Junio have been applied in this revision. Changes in v3: - rename is_port to port_num - directly return scalar value from getservbyname in port_num Thanks, Maxim Cournoyer (3): contrib: use a more portable shebang for git-credential-netrc contrib: warn for invalid netrc file ports in git-credential-netrc contrib: better support symbolic port names in git-credential-netrc contrib/credential/netrc/git-credential-netrc.perl | 14 +++++++++++--- contrib/credential/netrc/test.pl | 8 ++++---- git-send-email.perl | 11 +++++++++++ perl/Git.pm | 13 +++++++++++++ t/t9001-send-email.sh | 7 +++++++ 5 files changed, 46 insertions(+), 7 deletions(-) -- 2.49.0