From: Jeff King Date: Thu, 15 May 2025 19:55:36 GMT Subject: Re: [PATCH 04/11] upload-pack: rename `enum` to reflect the operation Message-ID: <20250515195536.GE3320240@coredump.intra.peff.net> In-Reply-To: <8d712a0ebc8d5161bdc80bdd7f4d05a967c66a09.1747314709.git.gitgitgadget@gmail.com> On Thu, May 15, 2025 at 01:11:42PM +0000, Johannes Schindelin via GitGitGadget wrote: > While 3145ea957d (upload-pack: introduce fetch server command, > 2018-03-15) added support for the `fetch` command, from the server's > point of view it is an upload, and hence the `enum` should really be > called `upload_state` instead of `fetch_state`. Likewise, rename its > values. > > This also helps unconfuse CodeQL which would otherwise be at sixes or > sevens about having _two_ non-local definitions of the same `enum` with > the same values. It unconfuses me, too. Nice change. -Peff