From: SZEDER Gábor Date: Sun, 19 Mar 2023 16:56:45 GMT Subject: [PATCH 0/3] parse-options.h: use designated initializers in OPT_* macros Message-ID: <20230319165648.656738-1-szeder.dev@gmail.com> Use designated initializers in the expansions of the OPT_* macros to make it more readable which one-letter macro parameter initializes which field in the resulting 'struct option'. SZEDER Gábor (3): parse-options.h: use consistent name for the callback parameters parse-options.h: rename _OPT_CONTAINS_OR_WITH()'s parameters parse-options.h: use designated initializers in OPT_* macros parse-options.h | 311 +++++++++++++++++++++++++++++++++++++----------- 1 file changed, 244 insertions(+), 67 deletions(-) -- 2.40.0.499.g88fa0b00d2