From: Teng Long Date: Thu, 12 Aug 2021 08:05:42 GMT Subject: Re: [PATCH v1 1/1] list-objects.c: traverse_trees_and_blobs: rename and tree-wide Message-ID: <20210812080542.5469-1-dyroneteng@gmail.com> In-Reply-To: >>FWIW, I was about reply and suggest the exact same name. :) >> >>As something internal to list-objects.c, I don't think it matters all >>that much either way. The name "traverse_commit_list()" is IMHO more >>likely to confuse. It is public within the project, and of course >>traverses any type of object. So "traverse_objects()" or something may >>be more accurate. On the basis of understanding the relationship between git objects, `traverse_commit_list` is understandable, for me. >>OTOH I do not find it all that confusing, and it may not be worth the >>disruption to the code base. Agree. It’s interesting to read your reply, because of learning a lot of abbreviations. Thank you.