From: Felipe Contreras Date: Sun, 25 Oct 2020 03:13:32 GMT Subject: [PATCH v2 18/29] completion: zsh: simplify nl_append Message-ID: <20201025031343.346913-19-felipe.contreras@gmail.com> In-Reply-To: <20201025031343.346913-1-felipe.contreras@gmail.com> It's exactly the same as __gitcomp_nl(), no need to duplicate code. Signed-off-by: Felipe Contreras --- contrib/completion/git-completion.zsh | 5 +---- 1 file changed, 1 insertion(+), 4 deletions(-) diff --git a/contrib/completion/git-completion.zsh b/contrib/completion/git-completion.zsh index f0babc784a..85365bd2f7 100644 --- a/contrib/completion/git-completion.zsh +++ b/contrib/completion/git-completion.zsh @@ -112,10 +112,7 @@ __gitcomp_nl () __gitcomp_nl_append () { - emulate -L zsh - - compset -P '*[=:]' - compadd -Q -S "${4- }" -p "${2-}" -- ${(f)1} && _ret=0 + __gitcomp_nl "$@" } __gitcomp_file_direct () -- 2.29.0