From: Øystein Walle Date: Mon, 15 Jun 2020 14:02:36 GMT Subject: Re: [PATCH v4 4/8] cmake: support for testing git with ctest Message-ID: <20200615140236.1707-1-oystwa@gmail.com> In-Reply-To: > + > +if(BUILD_TESTING) > + This variable should perhaps be declared as an option using option()[1] since it's a knob the user is supposed to be able to switch. This makes it listed by `cmake -L`, and shown in ccmake and cmake-gui. In short, it's made more disoverable. > file(APPEND ...) > file(APPEND ...) > file(APPEND ...) > (...) Maybe make this one multiline string and have one file(APPEND ...) at the end? It looks a bit... big. Øsse [1]: ttps://cmake.org/cmake/help/v3.18/command/option.html